1. Начало
  2. WordPress
  3. WordPress 5.2+ изисква минимум PHP 5.6 (WordPress 5.2.1 requires at least PHP 5.6.20)

WordPress 5.2+ изисква минимум PHP 5.6 (WordPress 5.2.1 requires at least PHP 5.6.20)

За WordPress версия 5.2 и следващи минималната необходима версия на PHP е 5.6.

Ако сайтът работи към момента с по-ниска от 5.6 версия на PHP, при обновяване на WordPress може да се получи съобщение за грешка:

"Your server is running PHP version 5.3.29 but WordPress 5.2.1 requires at least 5.6.20."

В случай че получите подобно съобщение на Вашия сайт, ще е нужно да превключите към по-висока версия на PHP.

За да активирате по-нова версия на PHP за сайта, следвайте стъпките:

1. Влезте в контролния панел cPanel на хостинг акаунта.

🔗 Достъп до cPanel чрез ползване на сигурна (SSL) връзка | Help

2. Заредете PHP Manager by SuperHosting.

🔗 Избор на PHP версия за хостинг акаунта | Help

3. Маркирайте PHP версия 7.1 или 7.2 или 7.3 и запишете промените с бутон Промени.

4. Проверете зареждането на сайта и административния му панел.

5. В случай че на сайта или на страницата за логин в административния панел видите съобщение, че в момента сайтът изпитва технически проблем, активирайте "режим на възстановяване". В режим на възстановяване можете да деактивирате проблемните плъгини, които не могат да функционират с новата версия на PHP. След като деактивирате проблемните плъгини, функционирането на сайта трябва да се възобнови.

За да активирате режим на възстановяване на сайта и да проверите проблемните плъгини, следвайте стъпките:

1. Проверете за получено писмо в пощенската кутия на административния имейл адрес. Това е имейл адресът, който е зададен за администратора на сайта в WordPress.

2. Кликнете на линка в полученото писмо с тема “Your Site is Experiencing a Technical Issue”.

3. След като страницата за логин се зареди, влезте в административния панел на WordPress.

4. Заредете страницата с плъгини и отворете раздел “Paused”.

5. Проверете проблемния плъгин.

Вариантите са няколко:

  • Можете да деактивирате за постоянно проблемния плъгин/и. Ако е темата на сайта, можете да активирате друга тема.
  • Можете сами да отстраните проблема в кода на плъгина/темата, като нанесете нужните корекции.
  • Можете да се обърнете към разработчиците на плъгина/темата, които да съдействат с отстраняването на проблема в кода на тяхната разработка.

6. След като проблемният плъгин/тема са обработени, можете да деактивирате режима на възстановяване с бутона в администрацията “Exit Recovery Mode”.

В случай че срещнете затруднение със стъпките и възстановяването на достъпа до сайта, изпратете запитване да нашата поддръжка по чат (на нашия сайт) или с имейл до support@superhosting.bg.

Обновена: 03.07.2019

Беше ли Ви полезна тази статия?

Вижте още